Difference between revisions of "Template:Project stats"

From The Uniform Server Wiki
Jump to navigation Jump to search
m (Text replace - "sourceforge.net/projects/miniserver" to "sourceforge.net/projects/uniformserver")
m (Text replace - "projects/uniformserver" to "projects/miniserver")
Line 19: Line 19:
 
To keep The Uniform Server footprint small, support for the PHP Internationalization extension is provided as a separate plugin. The Internationalization extension (Intl) is a wrapper for the ICU (International Components for Unicode) library.  Since it is tied to PHP,  
 
To keep The Uniform Server footprint small, support for the PHP Internationalization extension is provided as a separate plugin. The Internationalization extension (Intl) is a wrapper for the ICU (International Components for Unicode) library.  Since it is tied to PHP,  
 
be SURE that you download the matching version.  The current versions are:
 
be SURE that you download the matching version.  The current versions are:
*For Coral_8.5.3, which uses PHP 5.4.2, use [http://sourceforge.net/projects/uniformserver/files/Plugins/UniServer%208-Coral%20Plugins/Coral_Intl Coral_Intl_8_4_2.exe.]
+
*For Coral_8.5.3, which uses PHP 5.4.2, use [http://sourceforge.net/projects/miniserver/files/Plugins/UniServer%208-Coral%20Plugins/Coral_Intl Coral_Intl_8_4_2.exe.]
*For Coral_8.4.0 through Coral_8.5.1, which use PHP 5.4.0, use [http://sourceforge.net/projects/uniformserver/files/Plugins/UniServer%208-Coral%20Plugins/Coral_Intl Coral_Intl_8_4_0.exe.]
+
*For Coral_8.4.0 through Coral_8.5.1, which use PHP 5.4.0, use [http://sourceforge.net/projects/miniserver/files/Plugins/UniServer%208-Coral%20Plugins/Coral_Intl Coral_Intl_8_4_0.exe.]
*For Coral_8.1.1 through Coral_8.3.1, which use PHP 5.3.10, use [http://sourceforge.net/projects/uniformserver/files/Plugins/UniServer%208-Coral%20Plugins/Coral_Intl Coral_Intl_8_1_1.exe.]
+
*For Coral_8.1.1 through Coral_8.3.1, which use PHP 5.3.10, use [http://sourceforge.net/projects/miniserver/files/Plugins/UniServer%208-Coral%20Plugins/Coral_Intl Coral_Intl_8_1_1.exe.]
*For Coral_8.1.0, which uses PHP 5.3.9, use [http://sourceforge.net/projects/uniformserver/files/Plugins/UniServer%208-Coral%20Plugins/Coral_Intl Coral_Intl_8_1_0.exe.]
+
*For Coral_8.1.0, which uses PHP 5.3.9, use [http://sourceforge.net/projects/miniserver/files/Plugins/UniServer%208-Coral%20Plugins/Coral_Intl Coral_Intl_8_1_0.exe.]
 
Coral_8.0.0 installations should upgrade to a later version, at least 8.1.2.
 
Coral_8.0.0 installations should upgrade to a later version, at least 8.1.2.
  

Revision as of 16:18, 17 October 2012

The Uniform Server Development Status

Active and current:
Series 8-Coral: 100% READ THIS FIRST! --> DETAILED documentation (Yeah, even those of you who don't read manuals!)
This new version is a significant rewrite of the control programs.

  • The main controller is now an html application program (.hta) referred to as UniController.
  • The tray-based control panel has been modified to a plugin.
  • Apanel has been scrapped and its functions are now all in a server control panel in UniController.
  • A new, detailed documentation set in HTML format is included. This is the same information that's in this Wiki, meaning you don't have to be online to read it.

Coral UniTray Plugin: There are three version of Coral UniTray:

  • Basic: File Coral_Unitray_basic_8_1_0.exe
    Coral UniTray Basic provides menu items to launch either of the two UniController menus for running the servers as a standard program or as a service.
  • Intermediate: File Coral_Unitray_intermediate_8_1_0.exe
    Coral UniTray Intermediate, in addition to the basic version functionality, includes direct Apache and MySQL server control. It eliminates the need to first open the UniController menu before running servers as a standard program or as a service.
  • Full: File Coral_Unitray_full_8_1_0.exe
    Coral UniTray Full expands UniTray’s capabilities to include the most commonly used server utilities.

Coral Intl Plugin: To keep The Uniform Server footprint small, support for the PHP Internationalization extension is provided as a separate plugin. The Internationalization extension (Intl) is a wrapper for the ICU (International Components for Unicode) library. Since it is tied to PHP, be SURE that you download the matching version. The current versions are:

Coral_8.0.0 installations should upgrade to a later version, at least 8.1.2.


Series 7-Orion: 100% Support Material
This version is still current and under maintenance, but no new features will be added.

Future:
Cleanup, resolving errors and omissions in 8-Coral, and standard maintenance. :-)

Stable, but with outdated components:
Version 4.5-Mona: 100% Support Material

Version 5.7-Nano: 100% Support Material
Supplementary support for 5-Nano Series
This is also applicable to 7-Orion.

Series 6-Carbo.
Uses US Tray Menu 2 instead of The UniTray. Uses VC9 (Visual C++ 2008) instead of VC6 (Visual C++ 6.0).

Plug-In Development Status

Server Side Plugins

Admin Side Plugins

Future Development List